What’s Vulnerable › Vulnerabilities
CVE-2024-41121: Custom workspace allow to overwrite plugin entrypoint executable in Woodpecker
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-74
Description
Woodpecker is a simple yet powerful CI/CD engine with great extensibility. The server allow to create any user who can trigger a pipeline run malicious workflows: 1. Those workflows can either lead to a host takeover that runs the agent executing the workflow. 2. Or allow to extract the secrets who would be normally provided to the plugins who's entrypoint are overwritten. This issue has been addressed in release version 2.7.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- woodpecker-ci woodpecker: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: woodpecker-ci woodpecker 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/woodpecker-ci/woodpecker-security/issues/8
- https://github.com/woodpecker-ci/woodpecker-security/issues/9
- https://github.com/woodpecker-ci/woodpecker-security/pull/11
- https://github.com/woodpecker-ci/woodpecker/issues/3924
- https://github.com/woodpecker-ci/woodpecker/pull/3933
- https://github.com/woodpecker-ci/woodpecker/security/advisories/GHSA-xw35-rrcp-g7xm
- https://github.com/woodpecker-ci/woodpecker-security/issues/8
- https://github.com/woodpecker-ci/woodpecker-security/issues/9
- https://github.com/woodpecker-ci/woodpecker-security/pull/11
- https://github.com/woodpecker-ci/woodpecker/issues/3924
- https://github.com/woodpecker-ci/woodpecker/pull/3933
- https://github.com/woodpecker-ci/woodpecker/security/advisories/GHSA-xw35-rrcp-g7xm
Get alerted when CVE-2024-41121 or the next vulnerability affects your stack