What’s Vulnerable › Vulnerabilities
CVE-2024-41124: Puncia Cleartext Transmission of Sensitive Information via HTTP urls in `API_URLS`
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-19 · updated 2026-06-17
- Weakness: CWE-311
Description
Puncia is the Official CLI utility for Subdomain Center & Exploit Observer. `API_URLS` is utilizing HTTP instead of HTTPS for communication that can lead to issues like Eavesdropping, Data Tampering, Unauthorized Data Access & MITM Attacks. This issue has been addressed in release version 0.21 by using https rather than http connections. All users are advised to upgrade. There is no known workarounds for this vulnerability.
Affected products
- ARPSyndicate puncia: before 0.21 — fixed in 0.21
How to fix
Upgrade to a fixed version: ARPSyndicate puncia 0.21. Check the vendor advisory for mitigations.
References
- https://github.com/ARPSyndicate/puncia/commit/033f3b68126eabbb2040ce16e2c3a2ce17437fbd#diff-3ec6c2de51e702726b23c452e3f4a899f6f4253af9fbf5be7254a5c1407ab526
- https://github.com/ARPSyndicate/puncia/issues/8
- https://github.com/ARPSyndicate/puncia/security/advisories/GHSA-rwcj-7jjp-4w38
- https://github.com/ARPSyndicate/puncia/commit/033f3b68126eabbb2040ce16e2c3a2ce17437fbd#diff-3ec6c2de51e702726b23c452e3f4a899f6f4253af9fbf5be7254a5c1407ab526
- https://github.com/ARPSyndicate/puncia/issues/8
- https://github.com/ARPSyndicate/puncia/security/advisories/GHSA-rwcj-7jjp-4w38
Get alerted when CVE-2024-41124 or the next vulnerability affects your stack