What’s Vulnerable › Vulnerabilities
CVE-2024-41132: SixLabors ImageSharp Allows Excessive Memory Allocation in Gif Decoder
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-22 · updated 2026-06-17
- Weakness: CWE-789
Description
ImageSharp is a 2D graphics API. A vulnerability discovered in the ImageSharp library, where the processing of specially crafted files can lead to excessive memory usage in the Gif decoder. The vulnerability is triggered when ImageSharp attempts to process image files that are designed to exploit this flaw. All users are advised to upgrade to v3.1.5 or v2.1.9.
Affected products
- SixLabors ImageSharp: from 2.1.0 before 2.1.9; from 3.1.0 before 3.1.5 — fixed in 2.1.9, 3.1.5
How to fix
Upgrade to a fixed version: SixLabors ImageSharp 2.1.9, 3.1.5. Check the vendor advisory for mitigations.
References
- https://docs.sixlabors.com/articles/imagesharp.web/processingcommands.html#securing-processing-commands
- https://docs.sixlabors.com/articles/imagesharp/security.html
- https://github.com/SixLabors/ImageSharp/commit/59de13c8cc47f2b402e2c43aa7024511d029d515
- https://github.com/SixLabors/ImageSharp/commit/9816ca45016c5d3859986f3c600e8934bc450a56
- https://github.com/SixLabors/ImageSharp/commit/b496109051cc39feee1f6cde48fca6481de17f9a
- https://github.com/SixLabors/ImageSharp/pull/2759
- https://github.com/SixLabors/ImageSharp/pull/2764
- https://github.com/SixLabors/ImageSharp/pull/2770
- https://github.com/SixLabors/ImageSharp/security/advisories/GHSA-qxrv-gp6x-rc23
- https://docs.sixlabors.com/articles/imagesharp.web/processingcommands.html#securing-processing-commands
- https://docs.sixlabors.com/articles/imagesharp/security.html
- https://github.com/SixLabors/ImageSharp/commit/59de13c8cc47f2b402e2c43aa7024511d029d515
Get alerted when CVE-2024-41132 or the next vulnerability affects your stack