What’s Vulnerable › Vulnerabilities

CVE-2024-41144: Malicious remote can create/update/delete arbitrary posts in arbitrary channels

Description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to properly validate synced posts, when shared channels are enabled,  which allows a malicious remote to create/update/delete arbitrary posts in arbitrary channels

Affected products

How to fix

Upgrade to a fixed version: Mattermost 9.5.7, 9.7.6, 9.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-41144 or the next vulnerability affects your stack