What’s Vulnerable › Vulnerabilities
CVE-2024-41146
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-694
Description
Use of Multiple Resources with Duplicate Identifier (CWE-694) in the Controller 6000 and Controller 7000 Platforms could allow an attacker with physical access to HBUS communication cabling to perform a Denial-of-Service attack against HBUS connected devices, require a device reboot to resolve. This issue affects: Controller 6000 and Controller 7000 firmware versions 9.10 prior to vCR9.10.241108a (distributed in 9.10.2149 (MR4)), 9.00 prior to vCR9.00.241108a (distributed in 9.00.2374 (MR5)), 8.90 prior to vCR8.90.241107a (distributed in 8.90.2356 (MR6)), all versions of 8.80 and prior.
Affected products
- Gallagher Controller 6000 and Controller 7000: through 8.80; from 9.10 before vCR9.10.241108a; from 9.00 before vCR9.00.241108a; from 8.90 before vCR8.90.241107a — fixed in vCR8.90.241107a, vCR9.00.241108a, vCR9.10.241108a
How to fix
Upgrade to a fixed version: Gallagher Controller 6000 and Controller 7000 vCR8.90.241107a, vCR9.00.241108a, vCR9.10.241108a. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-41146 or the next vulnerability affects your stack