What’s Vulnerable › Vulnerabilities
CVE-2024-41151: Apache HertzBeat: RCE by notice template injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache HertzBeat. This vulnerability can only be exploited by authorized attackers. This issue affects Apache HertzBeat: before 1.6.1. Users are recommended to upgrade to version 1.6.1, which fixes the issue.
Affected products
- dromara hertzbeat: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: dromara hertzbeat 1.6.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/oor9nw6nh2ojnfw8d8oxrv40cbtk5mwj
- https://lists.apache.org/thread/p33tg0vo5nh6kscth4262ktsqo3h5lqo
- http://www.openwall.com/lists/oss-security/2024/11/16/6
Get alerted when CVE-2024-41151 or the next vulnerability affects your stack