What’s Vulnerable › Vulnerabilities
CVE-2024-41173: Beckhoff: Local authentication bypass in the IPC-Diagnostics package included in TwinCAT/BSD
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-27 · updated 2026-06-17
- Weakness: CWE-288
Description
The IPC-Diagnostics package included in TwinCAT/BSD is vulnerable to a local authentication bypass by a low privileged attacker.
Affected products
- Beckhoff IPC Diagnostics package: before 2.0.0.1 — fixed in 2.0.0.1
- Beckhoff Twincat/Bsd: before 14.1.2.0 — fixed in 14.1.2.0
How to fix
Upgrade to a fixed version: Beckhoff IPC Diagnostics package 2.0.0.1; Beckhoff Twincat/Bsd 14.1.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-41173 or the next vulnerability affects your stack