What’s Vulnerable › Vulnerabilities
CVE-2024-41175: Beckhoff: Local Denial-of-Service vulnerability in TwinCAT/BSD and the IPC-Diagnostics package
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-27 · updated 2026-06-17
- Weakness: CWE-770
Description
The IPC-Diagnostics package included in TwinCAT/BSD is vulnerable to a local denial-of-service attack by a low privileged attacker.
Affected products
- Beckhoff IPC Diagnostics package: before 2.0.0.1 — fixed in 2.0.0.1
- Beckhoff Twincat/Bsd: before 14.1.2.0 — fixed in 14.1.2.0
How to fix
Upgrade to a fixed version: Beckhoff IPC Diagnostics package 2.0.0.1; Beckhoff Twincat/Bsd 14.1.2.0. Check the vendor advisory for mitigations.
References
- https://cert.vde.com/en/advisories/VDE-2024-049/
- https://infosys.beckhoff.com/content/1033/twincat_bsd/11780818443.html?id=4222392218353411614
Get alerted when CVE-2024-41175 or the next vulnerability affects your stack