What’s Vulnerable › Vulnerabilities
CVE-2024-41177: Apache Zeppelin: XSS in the Helium module
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
Incomplete Blacklist to Cross-Site Scripting vulnerability in Apache Zeppelin. This issue affects Apache Zeppelin: before 0.12.0. Users are recommended to upgrade to version 0.12.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Zeppelin: before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/zeppelin/pull/4755
- https://github.com/apache/zeppelin/pull/4795
- https://lists.apache.org/thread/nwh8vh9f3pnvt04n8z4g2kbddh62blr6
- http://www.openwall.com/lists/oss-security/2025/08/03/4
Get alerted when CVE-2024-41177 or the next vulnerability affects your stack