What’s Vulnerable › Vulnerabilities
CVE-2024-4128: CSRF in firebase-tools emulator suite
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-02 · updated 2026-06-17
- Weakness: CWE-352
Description
This vulnerability was a potential CSRF attack. When running the Firebase emulator suite, there is an export endpoint that is used normally to export data from running emulators. If a user was running the emulator and navigated to a malicious website with the exploit on a browser that allowed calls to localhost (ie Chrome before v94), the website could exfiltrate emulator data. We recommend upgrading past version 13.6.0 or commit 068a2b08dc308c7ab4b569617f5fc8821237e3a0 https://github.com/firebase/firebase-tools/commit/068a2b08dc308c7ab4b569617f5fc8821237e3a0
Affected products
- firebase-tools: before 13.6.0 — fixed in 13.6.0
How to fix
Upgrade to a fixed version: firebase-tools 13.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/firebase/firebase-tools/commit/068a2b08dc308c7ab4b569617f5fc8821237e3a0
- https://github.com/firebase/firebase-tools/pull/6944
- https://github.com/firebase/firebase-tools/commit/068a2b08dc308c7ab4b569617f5fc8821237e3a0
- https://github.com/firebase/firebase-tools/pull/6944
Get alerted when CVE-2024-4128 or the next vulnerability affects your stack