What’s Vulnerable › Vulnerabilities
CVE-2024-4145: Search & Replace < 3.2.2 - Admin+ SQL injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-89
Description
The Search & Replace WordPress plugin before 3.2.2 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks (such as within a multi-site network).
Affected products
- WP MEDIA SAS Search & Replace: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: WP MEDIA SAS Search & Replace 3.2.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7d5b8764-c82d-4969-a707-f38b63bcadca/
- https://wpscan.com/vulnerability/7d5b8764-c82d-4969-a707-f38b63bcadca/
Get alerted when CVE-2024-4145 or the next vulnerability affects your stack