What’s Vulnerable › Vulnerabilities
CVE-2024-4147: Insufficient Access Control in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-02-02 · updated 2026-06-17
- Weakness: CWE-1220
Description
In lunary-ai/lunary version 1.2.13, an insufficient granularity of access control vulnerability allows users to delete prompts created in other organizations through ID manipulation. The vulnerability stems from the application's failure to validate the ownership of the prompt before deletion, only checking if the user has permissions to delete such resources without verifying if it belongs to the user's project or organization. As a result, users can remove prompts not owned by their organization or project, leading to legitimate users being unable to access the removed prompts and causing information inconsistencies.
Affected products
- lunary-ai/lunary: before 1.2.25 — fixed in 1.2.25
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.25. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/0755dde1afc2a74ec23b55eee03e4416916cf48f
- https://huntr.com/bounties/3f051943-71ea-414c-a528-cd8b5d82a7ad
Get alerted when CVE-2024-4147 or the next vulnerability affects your stack