What’s Vulnerable › Vulnerabilities
CVE-2024-4149: Floating Chat Widget < 3.2.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Floating Chat Widget: Contact Chat Icons, WhatsApp, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button WordPress plugin before 3.2.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- premio Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button – Chaty: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: premio Floating Chat Widget: Contact Chat Icons, Telegram Chat, Line Messenger, WeChat, Email, SMS, Call Button – Chaty 3.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0256ec2a-f1a9-4110-9978-ee88f9e24237/
- https://wpscan.com/vulnerability/0256ec2a-f1a9-4110-9978-ee88f9e24237/
Get alerted when CVE-2024-4149 or the next vulnerability affects your stack