What’s Vulnerable › Vulnerabilities
CVE-2024-4151: Improper Access Control in lunary-ai/lunary
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-20 · updated 2026-06-17
- Weakness: CWE-639
Description
An Improper Access Control vulnerability exists in lunary-ai/lunary version 1.2.2, where users can view and update any prompts in any projects due to insufficient access control checks in the handling of PATCH and GET requests for template versions. This vulnerability allows unauthorized users to manipulate or access sensitive project data, potentially leading to data integrity and confidentiality issues.
Affected products
- lunary-ai/lunary: before 1.2.25 — fixed in 1.2.25
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.2.25. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/ddfd497afd017a6946c582a1a806687fdac888bf
- https://huntr.com/bounties/4acfef85-dedf-43bd-8438-0d8aaa4ffa01
- https://huntr.com/bounties/4acfef85-dedf-43bd-8438-0d8aaa4ffa01
Get alerted when CVE-2024-4151 or the next vulnerability affects your stack