What’s Vulnerable › Vulnerabilities
CVE-2024-4158: Blocksy <= 2.0.42 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Blocksy theme for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘tagName’ parameter in versions up to, and including, 2.0.42 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- creativethemeshq Blocksy: before 2.0.43 — fixed in 2.0.43
How to fix
Upgrade to a fixed version: creativethemeshq Blocksy 2.0.43. Check the vendor advisory for mitigations.
References
- https://themes.trac.wordpress.org/changeset/226440/blocksy
- https://www.wordfence.com/threat-intel/vulnerabilities/id/22d1ccf3-ac1a-4dfc-81c3-b8eb88795bc1?source=cve
- https://themes.trac.wordpress.org/changeset/226440/blocksy
- https://www.wordfence.com/threat-intel/vulnerabilities/id/22d1ccf3-ac1a-4dfc-81c3-b8eb88795bc1?source=cve
Get alerted when CVE-2024-4158 or the next vulnerability affects your stack