What’s Vulnerable › Vulnerabilities

CVE-2024-41590

Description

Several CGI endpoints are vulnerable to buffer overflows, by authenticated users, because of missing bounds checking on parameters passed through POST requests to the strcpy function on DrayTek Vigor310 devices through 4.3.2.6.

Affected products

How to fix

Upgrade to a fixed version: DrayTek Vigor1000B Firmware 4.3.2.8, 4.4.3.1; DrayTek Vigor165 Firmware 4.2.7; DrayTek Vigor166 Firmware 4.2.7; DrayTek Vigor2135 Firmware 4.4.5.3; DrayTek Vigor2763 Firmware 4.4.5.3; DrayTek Vigor2765 Firmware 4.4.5.3; DrayTek Vigor2766 Firmware 4.4.5.3; DrayTek Vigor2865 Firmware 4.4.5.2; DrayTek Vigor2866 Firmware 4.4.5.2; DrayTek Vigor2915 Firmware 4.4.5.3; DrayTek Vigor2962 Firmware 4.3.2.8, 4.4.3.1; DrayTek Vigor3910 Firmware 4.3.2.8, 4.4.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-41590 or the next vulnerability affects your stack