What’s Vulnerable › Vulnerabilities
CVE-2024-41637
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-77
Description
RaspAP before 3.1.5 allows an attacker to escalate privileges: the www-data user has write access to the restapi.service file and also possesses Sudo privileges to execute several critical commands without a password.
Affected products
- raspap-webgui: before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: raspap-webgui 3.1.5. Check the vendor advisory for mitigations.
References
- https://blog.0xzon.dev/2024-07-27-CVE-2024-41637/
- https://github.com/RaspAP/raspap-webgui
- https://blog.0xzon.dev/2024-07-27-CVE-2024-41637/
- https://github.com/RaspAP/raspap-webgui
Get alerted when CVE-2024-41637 or the next vulnerability affects your stack