What’s Vulnerable › Vulnerabilities
CVE-2024-41656: Sentry vulnerable to stored Cross-Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Sentry is an error tracking and performance monitoring platform. Starting in version 10.0.0 and prior to version 24.7.1, an unsanitized payload sent by an Integration platform integration allows storing arbitrary HTML tags on the Sentry side with the subsequent rendering them on the Issues page. Self-hosted Sentry users may be impacted in case of untrustworthy Integration platform integrations sending external issues from their side to Sentry. A patch has been released in Sentry 24.7.1. For Sentry SaaS customers, no action is needed. This has been patched on July 23, and even prior to the fix, the exploitation was not possible due to the strict Content Security Policy deployed on sentry.io site. For self-hosted users, the maintainers of Sentry strongly recommend upgrading Sentry to the latest version. If it is not possible, one could enable CSP on one's self-hosted installation with `CSP_REPORT_ONLY = False` (enforcing mode). This will mitigate the risk of cross-site scripting.
Affected products
- getsentry sentry: from 10.0.0 before 24.7.1 — fixed in 24.7.1
How to fix
Upgrade to a fixed version: getsentry sentry 24.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/self-hosted/releases/tag/24.7.1
- https://github.com/getsentry/sentry/commit/5c679521f1539eabfb81287bfc30f34dbecd373e
- https://github.com/getsentry/sentry/pull/74648
- https://github.com/getsentry/sentry/security/advisories/GHSA-fm88-hc3v-3www
- https://github.com/getsentry/self-hosted/releases/tag/24.7.1
- https://github.com/getsentry/sentry/commit/5c679521f1539eabfb81287bfc30f34dbecd373e
- https://github.com/getsentry/sentry/pull/74648
- https://github.com/getsentry/sentry/security/advisories/GHSA-fm88-hc3v-3www
Get alerted when CVE-2024-41656 or the next vulnerability affects your stack