What’s Vulnerable › Vulnerabilities
CVE-2024-41665: Ampache Stored Cross-site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Ampache, a web based audio/video streaming application and file manager, has a stored cross-site scripting (XSS) vulnerability in versions prior to 6.6.0. This vulnerability exists in the "Playlists - Democratic - Configure Democratic Playlist" feature. An attacker with Content Manager permissions can set the Name field to `<svg onload=alert(8)>`. When any administrator or user accesses the Democratic functionality, they will be affected by this stored XSS vulnerability. The attacker can exploit this vulnerability to obtain the cookies of any user or administrator who accesses the `democratic.php` file. Version 6.6.0 contains a patch for the issue.
Affected products
- ampache: before 6.6.0 — fixed in 6.6.0
How to fix
Upgrade to a fixed version: ampache 6.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/ampache/ampache/security/advisories/GHSA-cp44-89r2-fxph
- https://github.com/ampache/ampache/security/advisories/GHSA-cp44-89r2-fxph
Get alerted when CVE-2024-41665 or the next vulnerability affects your stack