What’s Vulnerable › Vulnerabilities
CVE-2024-41675: CKAN has a Cross-site Scripting vector in the Datatables view plugin
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-79
Description
CKAN is an open-source data management system for powering data hubs and data portals. The Datatables view plugin did not properly escape record data coming from the DataStore, leading to a potential XSS vector. Sites running CKAN >= 2.7.0 with the datatables_view plugin activated. This is a plugin included in CKAN core, that not activated by default but it is widely used to preview tabular data. This vulnerability has been fixed in CKAN 2.10.5 and 2.11.0.
Affected products
- ckan: from 2.7.0 before 2.10.5 — fixed in 2.10.5
How to fix
Upgrade to a fixed version: ckan 2.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/ckan/ckan/commit/9e89ce8220ab1445e0bd85a67994a51d9d3d2688
- https://github.com/ckan/ckan/commit/d7dfe8c427b1c63c75d788a609f3b7d7620a25a1
- https://github.com/ckan/ckan/security/advisories/GHSA-r3jc-vhf4-6v32
Get alerted when CVE-2024-41675 or the next vulnerability affects your stack