What’s Vulnerable › Vulnerabilities
CVE-2024-41676: Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-79
Description
Magento-lts is a long-term support alternative to Magento Community Edition (CE). This XSS vulnerability affects the design/header/welcome, design/header/logo_src, design/header/logo_src_small, and design/header/logo_alt system configs.They are intended to enable admins to set a text in the two cases, and to define an image url for the other two cases. But because of previously missing escaping allowed to input arbitrary html and as a consequence also arbitrary JavaScript. The problem is patched with Version 20.10.1 or higher.
Affected products
- OpenMage magento-lts: before 20.10.1 — fixed in 20.10.1
How to fix
Upgrade to a fixed version: OpenMage magento-lts 20.10.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/484cf8afc550e98bbf2c03fbb29a8450a32e7948
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5vrp-638w-p8m2
- https://github.com/OpenMage/magento-lts/commit/484cf8afc550e98bbf2c03fbb29a8450a32e7948
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5vrp-638w-p8m2
Get alerted when CVE-2024-41676 or the next vulnerability affects your stack