What’s Vulnerable › Vulnerabilities
CVE-2024-41677: Cross-site Scripting (XSS) vulnerability due to improper HTML escaping in qwik
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Qwik is a performance focused javascript framework. A potential mutation XSS vulnerability exists in Qwik for versions up to but not including 1.6.0. Qwik improperly escapes HTML on server-side rendering. It converts strings according to the rules found in the `render-ssr.ts` file. It sometimes causes the situation that the final DOM tree rendered on browsers is different from what Qwik expects on server-side rendering. This may be leveraged to perform XSS attacks, and a type of the XSS is known as mXSS (mutation XSS). This has been resolved in qwik version 1.6.0 and @builder.io/qwik version 1.7.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- QwikDev qwik: before 1.7.3 — fixed in 1.7.3
How to fix
Upgrade to a fixed version: QwikDev qwik 1.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/QwikDev/qwik/blob/v1.5.5/packages/qwik/src/core/render/ssr/render-ssr.ts#L1182-L1208
- https://github.com/QwikDev/qwik/commit/7e742eb3a1001542d795776c0317d47df8b9d64e
- https://github.com/QwikDev/qwik/security/advisories/GHSA-2rwj-7xq8-4gx4
Get alerted when CVE-2024-41677 or the next vulnerability affects your stack