What’s Vulnerable › Vulnerabilities
CVE-2024-41799: tgstation-server's DreamMaker environment files outside the deployment directory can be compiled and ran by insufficiently permissioned users
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-22
Description
tgstation-server is a production scale tool for BYOND server management. Prior to 6.8.0, low permission users using the "Set .dme Path" privilege could potentially set malicious .dme files existing on the host machine to be compiled and executed. These .dme files could be uploaded via tgstation-server (requiring a separate, isolated privilege) or some other means. A server configured to execute in BYOND's trusted security level (requiring a third separate, isolated privilege OR being set by another user) could lead to this escalating into remote code execution via BYOND's shell() proc. The ability to execute this kind of attack is a known side effect of having privileged TGS users, but normally requires multiple privileges with known weaknesses. This vector is not intentional as it does not require control over the where deployment code is sourced from and _may_ not require remote write access to an instance's `Configuration` directory. This problem is fixed in versions 6.8.0 and above.
Affected products
- tgstation-server: from 4.0.0 before 6.8.0 — fixed in 6.8.0
How to fix
Upgrade to a fixed version: tgstation-server 6.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/tgstation/tgstation-server/commit/374852fe5ae306415eb5aafb2d16b06897d7afe4
- https://github.com/tgstation/tgstation-server/pull/1835
- https://github.com/tgstation/tgstation-server/security/advisories/GHSA-c3h4-9gc2-f7h4
- https://github.com/tgstation/tgstation-server/commit/374852fe5ae306415eb5aafb2d16b06897d7afe4
- https://github.com/tgstation/tgstation-server/pull/1835
- https://github.com/tgstation/tgstation-server/security/advisories/GHSA-c3h4-9gc2-f7h4
Get alerted when CVE-2024-41799 or the next vulnerability affects your stack