What’s Vulnerable › Vulnerabilities
CVE-2024-4180: The Events Calendar < 6.4.0.1 - Reflected XSS
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Events Calendar WordPress plugin before 6.4.0.1 does not properly sanitize user-submitted content when rendering some views via AJAX.
Affected products
- stellarwp The Events Calendar: before 6.4.0.1 — fixed in 6.4.0.1
How to fix
Upgrade to a fixed version: stellarwp The Events Calendar 6.4.0.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b2a92316-e404-4a5e-8426-f88df6e87550/
- https://wpscan.com/vulnerability/b2a92316-e404-4a5e-8426-f88df6e87550/
Get alerted when CVE-2024-4180 or the next vulnerability affects your stack