What’s Vulnerable › Vulnerabilities
CVE-2024-41809: OpenObserve Cross-site Scripting (XSS) vulnerability in `openobserve/web/src/views/MemberSubscription.vue`
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenObserve is an open-source observability platform. Starting in version 0.4.4 and prior to version 0.10.0, OpenObserve contains a cross-site scripting vulnerability in line 32 of `openobserve/web/src/views/MemberSubscription.vue`. Version 0.10.0 sanitizes incoming html.
Affected products
- openobserve: from 0.4.4 before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: openobserve 0.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/openobserve/openobserve/blob/v0.5.2/web/src/views/MemberSubscription.vue#L32
- https://github.com/openobserve/openobserve/commit/2334377ebc8b74beb06ab3e5712dbdb1be1eff02
- https://github.com/openobserve/openobserve/commit/64587261968217dfb8af4c4f6054d58bbc6d331d
- https://github.com/openobserve/openobserve/security/advisories/GHSA-rw8w-37p9-mrrp
- https://github.com/openobserve/openobserve/blob/v0.5.2/web/src/views/MemberSubscription.vue#L32
- https://github.com/openobserve/openobserve/commit/2334377ebc8b74beb06ab3e5712dbdb1be1eff02
- https://github.com/openobserve/openobserve/commit/64587261968217dfb8af4c4f6054d58bbc6d331d
- https://github.com/openobserve/openobserve/security/advisories/GHSA-rw8w-37p9-mrrp
Get alerted when CVE-2024-41809 or the next vulnerability affects your stack