What’s Vulnerable › Vulnerabilities
CVE-2024-4181: Command Injection in run-llama/llama_index
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-05-16 · updated 2026-06-17
- Weakness: CWE-94
Description
A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.
Affected products
- run-llama/llama_index: from 0.9.47 before 0.10.13 — fixed in 0.10.13
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.10.13. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba
- https://huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1
- https://github.com/run-llama/llama_index/commit/d73715eaf0642705583e7897c78b9c8dd2d3a7ba
- https://huntr.com/bounties/1a204520-598a-434e-b13d-0d34f2a5ddc1
Get alerted when CVE-2024-4181 or the next vulnerability affects your stack