What’s Vulnerable › Vulnerabilities
CVE-2024-41813: txtdot SSRF vulnerability in /proxy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-26 · updated 2026-06-17
- Weakness: CWE-918
Description
txtdot is an HTTP proxy that parses only text, links, and pictures from pages, removing ads and heavy scripts. Starting in version 1.4.0 and prior to version 1.6.1, a Server-Side Request Forgery (SSRF) vulnerability in the `/proxy` route of txtdot allows remote attackers to use the server as a proxy to send HTTP GET requests to arbitrary targets and retrieve information in the internal network. Version 1.6.1 patches the issue.
Affected products
- txtdot: from 1.4.0 before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: txtdot 1.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/TxtDot/txtdot/blob/a7fdaf80fdf45abefe83b2eb5135ba112142dc74/src/handlers/distributor.ts#L43-L47
- https://github.com/TxtDot/txtdot/commit/f241a46e05b148a39b84bf956051b5aaa489949e
- https://github.com/TxtDot/txtdot/security/advisories/GHSA-4c78-229v-hf6m
- https://github.com/TxtDot/txtdot/blob/a7fdaf80fdf45abefe83b2eb5135ba112142dc74/src/handlers/distributor.ts#L43-L47
- https://github.com/TxtDot/txtdot/commit/f241a46e05b148a39b84bf956051b5aaa489949e
- https://github.com/TxtDot/txtdot/security/advisories/GHSA-4c78-229v-hf6m
Get alerted when CVE-2024-41813 or the next vulnerability affects your stack