What’s Vulnerable › Vulnerabilities
CVE-2024-41816: WordPress Cooked Plugin Persistent Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Cooked is a recipe plugin for WordPress. The Cooked plugin for WordPress is vulnerable to Persistent Cross-Site Scripting (XSS) via the ‘[cooked-timer]’ shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping. This vulnerability allows authenticated attackers with subscriber-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses a compromised page. This issue has been addressed in release version 1.8.1. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- XjSv Cooked: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: XjSv Cooked 1.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/XjSv/Cooked/commit/ac7455bdccc99fb2f5b3c7611312947c1623c3ec
- https://github.com/XjSv/Cooked/security/advisories/GHSA-3gw3-2qjq-xqjj
Get alerted when CVE-2024-41816 or the next vulnerability affects your stack