What’s Vulnerable › Vulnerabilities
CVE-2024-41817: Arbitrary Code Execution in `AppImage` version `ImageMagick`
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-427
Description
ImageMagick is a free and open-source software suite, used for editing and manipulating digital images. The `AppImage` version `ImageMagick` might use an empty path when setting `MAGICK_CONFIGURE_PATH` and `LD_LIBRARY_PATH` environment variables while executing, which might lead to arbitrary code execution by loading malicious configuration files or shared libraries in the current working directory while executing `ImageMagick`. The vulnerability is fixed in 7.11-36.
Affected products
- ImageMagick: from 7.0.11-13 before 7.1.1-36 — fixed in 7.1.1-36
How to fix
Upgrade to a fixed version: ImageMagick 7.1.1-36. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/blob/3b22378a23d59d7517c43b65b1822f023df357a0/app-image/AppRun#L11-L14
- https://github.com/ImageMagick/ImageMagick/commit/6526a2b28510ead6a3e14de711bb991ad9abff38
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8rxc-922v-phg8
- https://github.com/ImageMagick/ImageMagick/blob/3b22378a23d59d7517c43b65b1822f023df357a0/app-image/AppRun#L11-L14
- https://github.com/ImageMagick/ImageMagick/commit/6526a2b28510ead6a3e14de711bb991ad9abff38
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-8rxc-922v-phg8
Get alerted when CVE-2024-41817 or the next vulnerability affects your stack