What’s Vulnerable › Vulnerabilities

CVE-2024-4182

Description

Mattermost versions 9.6.0, 9.5.x before 9.5.3, 9.4.x before 9.4.5, and 8.1.x before 8.1.12 fail to handle JSON parsing errors in custom status values, which allows an authenticated attacker to crash other users' web clients via a malformed custom status.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.12, 9.4.5, 9.5.3, 9.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4182 or the next vulnerability affects your stack