What’s Vulnerable › Vulnerabilities

CVE-2024-4183

Description

Mattermost versions 8.1.x before 8.1.12, 9.6.x before 9.6.1, 9.5.x before 9.5.3, 9.4.x before 9.4.5 fail to limit the number of active sessions, which allows an authenticated attacker to crash the server via repeated requests to the getSessions API after flooding the sessions table.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 8.1.12, 9.4.5, 9.5.3, 9.6.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4183 or the next vulnerability affects your stack