What’s Vulnerable › Vulnerabilities

CVE-2024-41856: Illustrator | Improper Input Validation (CWE-20)

Description

Illustrator versions 28.5, 27.9.4, 28.6, 27.9.5 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Illustrator 27.9.5, 28.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-41856 or the next vulnerability affects your stack