What’s Vulnerable › Vulnerabilities
CVE-2024-41915: Authenticated SQL Injection Vulnerability in ClearPass Policy Manager Web-based Management Interface
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability in the web-based management interface of ClearPass Policy Manager could allow an authenticated remote attacker to conduct SQL injection attacks against the ClearPass Policy Manager instance. An attacker could exploit this vulnerability to obtain and modify sensitive information in the underlying database potentially leading to complete compromise of the ClearPass Policy Manager cluster.
Affected products
- Aruba ClearPass Policy Manager: from 6.11.0 before 6.11.9; from 6.12.0 before 6.12.2 — fixed in 6.11.9, 6.12.2
How to fix
Upgrade to a fixed version: Aruba ClearPass Policy Manager 6.11.9, 6.12.2. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw04675en_us&docLocale=en_US
- https://support.hpe.com/hpesc/public/docDisplay?docId=hpesbnw04675en_us&docLocale=en_US
Get alerted when CVE-2024-41915 or the next vulnerability affects your stack