What’s Vulnerable › Vulnerabilities

CVE-2024-41926: Malicious remote can claim that a user was synced from another remote

Description

Mattermost versions 9.9.x <= 9.9.0 and 9.5.x <= 9.5.6 fail to validate the source of sync messages and only allow the correct remote IDs, which allows a malicious remote to set arbitrary RemoteId values for synced users and therefore claim that a user was synced from another remote.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 9.5.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-41926 or the next vulnerability affects your stack