What’s Vulnerable › Vulnerabilities
CVE-2024-41937: Apache Airflow: Stored XSS Vulnerability on provider link
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Apache Airflow, versions before 2.10.0, have a vulnerability that allows the developer of a malicious provider to execute a cross-site scripting attack when clicking on a provider documentation link. This would require the provider to be installed on the web server and the user to click the provider link. Users should upgrade to 2.10.0 or later, which fixes this vulnerability.
Affected products
- Apache Airflow: before 2.10.0 — fixed in 2.10.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/40933
- https://lists.apache.org/thread/lwlmgg6hqfmkpvw5py4w53hxyl37jl6d
- http://www.openwall.com/lists/oss-security/2024/08/21/3
Get alerted when CVE-2024-41937 or the next vulnerability affects your stack