What’s Vulnerable › Vulnerabilities
CVE-2024-4195
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-26 · updated 2026-06-17
- Weakness: CWE-284
Description
Mattermost versions 9.6.0, 9.5.x before 9.5.3, and 8.1.x before 8.1.12 fail to fully validate role changes, which allows an attacker authenticated as a team admin to promote guests to team admins via crafted HTTP requests.
Affected products
- Mattermost: from 8.1.0 before 8.1.12; from 9.5.0 before 9.5.3 — fixed in 8.1.12, 9.5.3
How to fix
Upgrade to a fixed version: Mattermost 8.1.12, 9.5.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4195 or the next vulnerability affects your stack