What’s Vulnerable › Vulnerabilities
CVE-2024-41964: Insufficient permission checks in the language settings in Kirby CMS
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-863
Description
Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.
Affected products
- getkirby kirby: before 3.6.6.6; from 3.7.0 before 3.7.5.5; from 3.8.0 before 3.8.4.4; from 3.9.0 before 3.9.8.2; from 3.10.0 before 3.10.1.1; from 4.0.0 before 4.3.1 — fixed in 3.10.1.1, 3.6.6.6, 3.7.5.5, 3.8.4.4, 3.9.8.2, 4.3.1
How to fix
Upgrade to a fixed version: getkirby kirby 3.10.1.1, 3.6.6.6, 3.7.5.5, 3.8.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/getkirby/kirby/commit/ab95d172667c3cd529917c2bc94d3c7969706d23
- https://github.com/getkirby/kirby/security/advisories/GHSA-jm9m-rqr3-wfmh
Get alerted when CVE-2024-41964 or the next vulnerability affects your stack