What’s Vulnerable › Vulnerabilities
CVE-2024-41991
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-06-17
- Weakness: CWE-1284
Description
An issue was discovered in Django 5.0 before 5.0.8 and 4.2 before 4.2.15. The urlize and urlizetrunc template filters, and the AdminURLFieldWidget widget, are subject to a potential denial-of-service attack via certain inputs with a very large number of Unicode characters.
Affected products
- Django: from 4.2 before 4.2.15; from 5.0 before 5.0.8 — fixed in 4.2.15, 5.0.8
How to fix
Upgrade to a fixed version: Django 4.2.15, 5.0.8. Check the vendor advisory for mitigations.
References
- https://docs.djangoproject.com/en/dev/releases/security/
- https://groups.google.com/forum/#%21forum/django-announce
- https://www.djangoproject.com/weblog/2024/aug/06/security-releases/
- https://security.netapp.com/advisory/ntap-20240905-0007/
Get alerted when CVE-2024-41991 or the next vulnerability affects your stack