What’s Vulnerable › Vulnerabilities
CVE-2024-41997
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-14 · updated 2026-06-17
- Weakness: CWE-94
Description
An issue was discovered in version of Warp Terminal prior to 2024.07.18 (v0.2024.07.16.08.02). A command injection vulnerability exists in the Docker integration functionality. An attacker can create a specially crafted hyperlink using the `warp://action/docker/open_subshell` intent that when clicked by the victim results in command execution on the victim's machine.
Affected products
- Warp Terminal: before 2024.07.18 — fixed in 2024.07.18
How to fix
Upgrade to a fixed version: Warp Terminal 2024.07.18. Check the vendor advisory for mitigations.
References
- https://docs.warp.dev/features/integrations-and-plugins#docker
- https://docs.warp.dev/getting-started/changelog#id-2024.07.18-v0.2024.07.16.08.02
- https://gist.github.com/bhyh/d1ee7a825fce283bf8acbdb42c8a7832
- https://github.com/warpdotdev/warp
Get alerted when CVE-2024-41997 or the next vulnerability affects your stack