What’s Vulnerable › Vulnerabilities
CVE-2024-42008
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 34.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-05 · updated 2026-06-17
- Weakness: CWE-79
Description
A Cross-Site Scripting vulnerability in rcmail_action_mail_get->run() in Roundcube through 1.5.7 and 1.6.x through 1.6.7 allows a remote attacker to steal and send emails of a victim via a malicious e-mail attachment served with a dangerous Content-Type header.
Affected products
- Roundcube Webmail: before 1.5.8; from 1.6.0 before 1.6.8 — fixed in 1.5.8, 1.6.8
How to fix
Upgrade to a fixed version: Roundcube Webmail 1.5.8, 1.6.8. Check the vendor advisory for mitigations.
References
- https://github.com/roundcube/roundcubemail/releases
- https://github.com/roundcube/roundcubemail/releases/tag/1.5.8
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.8
- https://roundcube.net/news/2024/08/04/security-updates-1.6.8-and-1.5.8
- https://sonarsource.com/blog/government-emails-at-risk-critical-cross-site-scripting-vulnerability-in-roundcube-webmail/
Get alerted when CVE-2024-42008 or the next vulnerability affects your stack