What’s Vulnerable › Vulnerabilities

CVE-2024-4201: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

A cross-site scripting issue has been discovered in GitLab affecting all versions starting from 5.1 before 16.10.7, all versions starting from 16.11 before 16.111.4, all versions starting from 17.0 before 17.0.2. When viewing an XML file in a repository in raw mode, it can be made to render as HTML if viewed under specific circumstances.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.7, 16.111.4, 17.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-4201 or the next vulnerability affects your stack