What’s Vulnerable › Vulnerabilities
CVE-2024-42025
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-13 · updated 2026-06-17
- Weakness: CWE-77
Description
A Command Injection vulnerability found in a Self-Hosted UniFi Network Servers (Linux) with UniFi Network Application (Version 8.3.32 and earlier) allows a malicious actor with unifi user shell access to escalate privileges to root on the host device.
Affected products
- Ubiquiti Inc UniFi Network Application: before 8.4.59 — fixed in 8.4.59
How to fix
Upgrade to a fixed version: Ubiquiti Inc UniFi Network Application 8.4.59. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42025 or the next vulnerability affects your stack