What’s Vulnerable › Vulnerabilities

CVE-2024-42059

Description

A post-authentication command injection vulnerability in Zyxel ATP series firmware versions from V5.00 through V5.38, USG FLEX series firmware versions from V5.00 through V5.38, USG FLEX 50(W) series firmware versions from V5.00 through V5.38, and USG20(W)-VPN series firmware versions from V5.00 through V5.38 could allow an authenticated attacker with administrator privileges to execute some OS commands on an affected device by uploading a crafted compressed language file via FTP.

Affected products

How to fix

Upgrade to a fixed version: Zyxel firewall (ZLD) 5.39. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-42059 or the next vulnerability affects your stack