What’s Vulnerable › Vulnerabilities
CVE-2024-42061
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-03 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected cross-site scripting (XSS) vulnerability in the CGI program "dynamic_script.cgi" of Zyxel ATP series firmware versions from V4.32 through V5.38, USG FLEX series firmware versions from V4.50 through V5.38, USG FLEX 50(W) series firmware versions from V4.16 through V5.38, and USG20(W)-VPN series firmware versions from V4.16 through V5.38 could allow an attacker to trick a user into visiting a crafted URL with the XSS payload. The attacker could obtain browser-based information if the malicious script is executed on the victim’s browser.
Affected products
- Zyxel firewall (ZLD): from 4.32 before 5.39; from 4.50 before 5.39; from 4.16 before 5.39 — fixed in 5.39
How to fix
Upgrade to a fixed version: Zyxel firewall (ZLD) 5.39. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-42061 or the next vulnerability affects your stack