What’s Vulnerable › Vulnerabilities
CVE-2024-42062: Apache CloudStack: User Key Exposure to Domain Admins
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-06-17
- Weakness: CWE-863
Description
CloudStack account-users by default use username and password based authentication for API and UI access. Account-users can generate and register randomised API and secret keys and use them for the purpose of API-based automation and integrations. Due to an access permission validation issue that affects Apache CloudStack versions 4.10.0 up to 4.19.1.0, domain admin accounts were found to be able to query all registered account-users API and secret keys in an environment, including that of a root admin. An attacker who has domain admin access can exploit this to gain root admin and other-account privileges and perform malicious operations that can result in compromise of resources integrity and confidentiality, data loss, denial of service and availability of CloudStack managed infrastructure. Users are recommended to upgrade to Apache CloudStack 4.18.2.3 or 4.19.1.1, or later, which addresses this issue. Additionally, all account-user API and secret keys should be regenerated.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.10.0.0 before 4.18.2.3; from 4.19.0.0 before 4.19.1.1 — fixed in 4.18.2.3, 4.19.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.18.2.3, 4.19.1.1. Check the vendor advisory for mitigations.
References
- https://cloudstack.apache.org/blog/security-release-advisory-4.19.1.1-4.18.2.3
- https://lists.apache.org/thread/lxqtfd6407prbw3801hb4fz3ot3t8wlj
- https://www.shapeblue.com/shapeblue-security-advisory-apache-cloudstack-security-releases-4-18-2-3-and-4-19-1-1/
- http://www.openwall.com/lists/oss-security/2024/08/06/5
Get alerted when CVE-2024-42062 or the next vulnerability affects your stack