What’s Vulnerable › Vulnerabilities
CVE-2024-42087: drm/panel: ilitek-ili9881c: Fix warning with GPIO controllers that sleep
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-29 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: drm/panel: ilitek-ili9881c: Fix warning with GPIO controllers that sleep The ilitek-ili9881c controls the reset GPIO using the non-sleeping gpiod_set_value() function. This complains loudly when the GPIO controller needs to sleep. As the caller can sleep, use gpiod_set_value_cansleep() to fix the issue.
Affected products
- Linux kernel: before 4.19.317; from 4.20 before 5.4.279; from 5.5 before 5.10.221; from 5.11 before 5.15.162; from 5.16 before 6.1.97; from 6.2 before 6.6.37 — fixed in 4.19.317, 5.10.221, 5.15.162, 5.4.279, 6.1.97, 6.6.37
How to fix
Upgrade to a fixed version: Linux kernel 4.19.317, 5.10.221, 5.15.162, 5.4.279. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1618f7a875ffd916596392fd29880c0429b8af60
- https://git.kernel.org/stable/c/489f38de3375ab84b3d269d0a1d64d6ee95d7044
- https://git.kernel.org/stable/c/5f41401219fbe7663b3cf65ebd4ed95ebbb8ffb9
- https://git.kernel.org/stable/c/98686ec1824728ff41d7b358131f7d0227c2ba2a
- https://git.kernel.org/stable/c/b71348be1236398be2d04c5e145fd6eaae86a91b
- https://git.kernel.org/stable/c/cae52f61fda0f5d2949dc177f984c9e187d4c6a0
- https://git.kernel.org/stable/c/e646402bf82145349fcf5dcbe395afaf02a8ce47
- https://git.kernel.org/stable/c/ee7860cd8b5763017f8dc785c2851fecb7a0c565
- https://git.kernel.org/stable/c/1618f7a875ffd916596392fd29880c0429b8af60
- https://git.kernel.org/stable/c/489f38de3375ab84b3d269d0a1d64d6ee95d7044
- https://git.kernel.org/stable/c/5f41401219fbe7663b3cf65ebd4ed95ebbb8ffb9
- https://git.kernel.org/stable/c/98686ec1824728ff41d7b358131f7d0227c2ba2a
Get alerted when CVE-2024-42087 or the next vulnerability affects your stack