What’s Vulnerable › Vulnerabilities
CVE-2024-42100: clk: sunxi-ng: common: Don't call hw_to_ccu_common on hw without common
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: clk: sunxi-ng: common: Don't call hw_to_ccu_common on hw without common In order to set the rate range of a hw sunxi_ccu_probe calls hw_to_ccu_common() assuming all entries in desc->ccu_clks are contained in a ccu_common struct. This assumption is incorrect and, in consequence, causes invalid pointer de-references. Remove the faulty call. Instead, add one more loop that iterates over the ccu_clks and sets the rate range, if required.
Affected products
- Linux kernel: from 6.6.31 before 6.6.39; from 6.8.10 before 6.9; from 6.9.1 before 6.9.9; 6.9, 6.9-rc7, 6.10-rc1, 6.10-rc2, 6.10-rc3, 6.10-rc4 (+2) — fixed in 6.6.39, 6.9, 6.9.9
How to fix
Upgrade to a fixed version: Linux kernel 6.6.39, 6.9, 6.9.9. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/14c78d69dbca6a28af14095f639ec4318ec07fdc
- https://git.kernel.org/stable/c/7a0e2738cb6da5a55c9908dff333600aeb263e07
- https://git.kernel.org/stable/c/ea977d742507e534d9fe4f4d74256f6b7f589338
- https://git.kernel.org/stable/c/14c78d69dbca6a28af14095f639ec4318ec07fdc
- https://git.kernel.org/stable/c/7a0e2738cb6da5a55c9908dff333600aeb263e07
- https://git.kernel.org/stable/c/ea977d742507e534d9fe4f4d74256f6b7f589338
Get alerted when CVE-2024-42100 or the next vulnerability affects your stack