What’s Vulnerable › Vulnerabilities
CVE-2024-42101: drm/nouveau: fix null pointer dereference in nouveau_connector_get_modes
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: drm/nouveau: fix null pointer dereference in nouveau_connector_get_modes In nouveau_connector_get_modes(), the return value of drm_mode_duplicate() is assigned to mode, which will lead to a possible NULL pointer dereference on failure of drm_mode_duplicate(). Add a check to avoid npd.
Affected products
- Linux kernel: from 2.6.33 before 4.19.318; from 4.20 before 5.4.280; from 5.5 before 5.10.222; from 5.11 before 5.15.163; from 5.16 before 6.1.98; from 6.2 before 6.6.39 — fixed in 4.19.318, 5.10.222, 5.15.163, 5.4.280, 6.1.98, 6.6.39
How to fix
Upgrade to a fixed version: Linux kernel 4.19.318, 5.10.222, 5.15.163, 5.4.280. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1f32535238493008587a8c5cb17eb2ca097592ef
- https://git.kernel.org/stable/c/274cba8d2d1b48c72d8bd90e76c9e2dc1aa0a81d
- https://git.kernel.org/stable/c/744b229f09134ccd091427a6f9ea6d97302cfdd9
- https://git.kernel.org/stable/c/7db5411c5d0bd9c29b8c2ad93c36b5c16ea46c9e
- https://git.kernel.org/stable/c/80bec6825b19d95ccdfd3393cf8ec15ff2a749b4
- https://git.kernel.org/stable/c/9baf60323efa992b7c915094529f0a1882c34e7e
- https://git.kernel.org/stable/c/e36364f5f3785d054a94e57e971385284886d41a
- https://git.kernel.org/stable/c/f48dd3f19614022f2e1b794fbd169d2b4c398c07
- https://git.kernel.org/stable/c/1f32535238493008587a8c5cb17eb2ca097592ef
- https://git.kernel.org/stable/c/274cba8d2d1b48c72d8bd90e76c9e2dc1aa0a81d
- https://git.kernel.org/stable/c/744b229f09134ccd091427a6f9ea6d97302cfdd9
- https://git.kernel.org/stable/c/7db5411c5d0bd9c29b8c2ad93c36b5c16ea46c9e
Get alerted when CVE-2024-42101 or the next vulnerability affects your stack