What’s Vulnerable › Vulnerabilities
CVE-2024-42121: drm/amd/display: Check index msg_id before read or write
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amd/display: Check index msg_id before read or write [WHAT] msg_id is used as an array index and it cannot be a negative value, and therefore cannot be equal to MOD_HDCP_MESSAGE_ID_INVALID (-1). [HOW] Check whether msg_id is valid before reading and setting. This fixes 4 OVERRUN issues reported by Coverity.
Affected products
- Linux kernel: from 4.15 before 5.10.222; from 5.11 before 5.15.163; from 5.16 before 6.1.98; from 6.2 before 6.6.39; from 6.7 before 6.9.9 — fixed in 5.10.222, 5.15.163, 6.1.98, 6.6.39, 6.9.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.222, 5.15.163, 6.1.98, 6.6.39. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/59d99deb330af206a4541db0c4da8f73880fba03
- https://git.kernel.org/stable/c/9933eca6ada0cd612e19522e7a319bcef464c0eb
- https://git.kernel.org/stable/c/a31ea49dc8064a557565725cf045944307476a6e
- https://git.kernel.org/stable/c/ae91ffbc8b8d942e3e7f188728cad557b7ed5ee4
- https://git.kernel.org/stable/c/b5b8837d066cc182ff69fb5629ad32ade5484567
- https://git.kernel.org/stable/c/fbb0701af9734cff13917a4b98b5ee9da2fde48d
- https://git.kernel.org/stable/c/59d99deb330af206a4541db0c4da8f73880fba03
- https://git.kernel.org/stable/c/9933eca6ada0cd612e19522e7a319bcef464c0eb
- https://git.kernel.org/stable/c/a31ea49dc8064a557565725cf045944307476a6e
- https://git.kernel.org/stable/c/ae91ffbc8b8d942e3e7f188728cad557b7ed5ee4
- https://git.kernel.org/stable/c/b5b8837d066cc182ff69fb5629ad32ade5484567
- https://git.kernel.org/stable/c/fbb0701af9734cff13917a4b98b5ee9da2fde48d
Get alerted when CVE-2024-42121 or the next vulnerability affects your stack