What’s Vulnerable › Vulnerabilities
CVE-2024-42124: scsi: qedf: Make qedf_execute_tmf() non-preemptible
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-30 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: qedf: Make qedf_execute_tmf() non-preemptible Stop calling smp_processor_id() from preemptible code in qedf_execute_tmf90. This results in BUG_ON() when running an RT kernel. [ 659.343280] BUG: using smp_processor_id() in preemptible [00000000] code: sg_reset/3646 [ 659.343282] caller is qedf_execute_tmf+0x8b/0x360 [qedf]
Affected products
- Linux kernel: from 4.11 before 5.4.280; from 5.5 before 5.10.222; from 5.11 before 5.15.163; from 5.16 before 6.1.98; from 6.2 before 6.6.39; from 6.7 before 6.9.9 — fixed in 5.10.222, 5.15.163, 5.4.280, 6.1.98, 6.6.39, 6.9.9
How to fix
Upgrade to a fixed version: Linux kernel 5.10.222, 5.15.163, 5.4.280, 6.1.98. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0a8a91932b2772e75bf3f6d133ca4225d1d3e920
- https://git.kernel.org/stable/c/0d8b637c9c5eeaa1a4e3dfb336f3ff918eb64fec
- https://git.kernel.org/stable/c/2b9c7787cfcd1e76d873a78f16cf45bfa4b100ea
- https://git.kernel.org/stable/c/4f314aadeed8cdf42c8cf30769425b5e44702748
- https://git.kernel.org/stable/c/5ceb40cdee721e13cbe15a0515cacf984e11236b
- https://git.kernel.org/stable/c/b6ded5316ec56e973dcf5f9997945aad01a9f062
- https://git.kernel.org/stable/c/fa49c65a1cec6a3901ef884fdb24d98068b63493
- https://git.kernel.org/stable/c/0a8a91932b2772e75bf3f6d133ca4225d1d3e920
- https://git.kernel.org/stable/c/0d8b637c9c5eeaa1a4e3dfb336f3ff918eb64fec
- https://git.kernel.org/stable/c/2b9c7787cfcd1e76d873a78f16cf45bfa4b100ea
- https://git.kernel.org/stable/c/4f314aadeed8cdf42c8cf30769425b5e44702748
- https://git.kernel.org/stable/c/5ceb40cdee721e13cbe15a0515cacf984e11236b
Get alerted when CVE-2024-42124 or the next vulnerability affects your stack